Working with documents

Working with documents

Learn how to work with the document list in harmon.ie:

Note: Some operations can be simultaneously performed on multiple documents.

Some of the operations are also available from the View > SharePoint and Edit > SharePoint application menus.

To delete a folder or a document:

To delete a selected document or folder from the SharePoint server, right-click the item and select Delete, or use the keyboard shortcut Delete. If you delete a folder, all contents inside the folder are removed. Deleted items are moved to the SharePoint site's Recycle Bin. You can restore deleted items from the Recycle Bin, which is available from SharePoint's Web interface.

Note: Sites and document libraries cannot be deleted from harmon.ie.

To rename a document:

To rename a document, right click the document and select Rename, then type the new name and click OK.

Note: If the document library has versioning support, you will be prompted to check out the document in order to rename it. Then, check it back in.

To open in browser:

Right-click a subsite, document library, folder, or document, and select Open in Browser to open the SharePoint item in a Web browser. The IBM Notes setting File > Preferences > Web Browser determines if the page opens in Notes' embedded Web browser or in the default browser set in Windows.

The Open in Browser operation is also available from the context menu of the breadcrumbs, located in the navigation & search omnibox above the document list. Right-clicking the right-most element in the breadcrumbs is the easiest way to open the current location in the browser.

You can open a SharePoint site or document library in the web browser from the breadcrumbs context menu.

Clipboard operations

You can use standard clipboard operations (Cut, Copy, and Paste) to move and copy documents between different locations on SharePoint, IBM Notes, and your computer. These operations are available from the sidebar's document context menu.

You can use standard clipboard operations to move and copy documents between locations on SharePoint, Notes and your computer.

Use the Copy command menu to:

  • Copy the Document itself.
  • Copy a Link to the document. This option places the document name with a hyperlink to its location on the Clipboard.
  • Copy a Link (Document ID) to the document. This option places the document name with a hyperlink to its document ID on the Clipboard. This option is available if the library contains a Document ID property.
  • Copy the Address of the document. This option places the URL of the document on the Clipboard. The Copy Address command is also available for subsites, libraries, and folders, and in the breadcrumbs context menu in the sidebar status bar.

  • The breadcrumbs context menu lets you copy the address of the current and parent locations.

Note: The Ctrl+C keyboard shortcut works similar to dragging-and-dropping files from the sidebar. By default, a document link is copied when you select Ctrl+C. Use harmon.ie settings to change the default action when copying SharePoint documents with Ctrl+C.

Use the Cut command to move documents inside the harmon.ie sidebar:

Notes:

  • When cutting and pasting to IBM Notes or to your computer, the command behaves as the Copy command.
  • When using the Cut command and pasting the document to another document library, the document’s meta-information, including document properties, workflows, approval status, version history and content type, is lost.

To approve or reject documents/items:

  1. If major and minor versions are being tracked in a document library that requires content approval, you must publish the document/item first.
  2. Right-click the document/item and select Approve/Reject.
  3. Mark the document as Approved, Rejected, or Pending. Optionally enter a comment about why the document was approved or rejected.
  4. Click OK.